Bug Tracker

Ticket #4360 (closed bug: invalid)

Opened 6 years ago

Last modified 4 years ago

Internet Explorer 7 .load event fails to set the content length when parameters are sent

Reported by: Iann Owned by:
Priority: major Milestone: 1.4
Component: ajax Version: 1.3.2
Keywords: Cc:
Blocking: Blocked by:

Description

Trying to run the following load command. Works fine in FF3.1, Chrome 1, Safari 3. Doesn't work in IE7.

$(me.grid).html('loading data...').load(me.viewType, {

view : + id ,page : + me.pageNum ,rnd : + (new Date()).getTime()

}, me.dataLoaded);

Investigating this, I have found that it is sending a POST request, with a content-length of 0 (zero).

Headers provided by debugbar v5.2:

POST /Aktiv3/ITSupport/Jobs/ViewRequests.vml HTTP/1.1 x-requested-with: XMLHttpRequest Accept-Language: en-gb Referer:  http://localhost:8084/Aktiv3/ITSupport/Jobs/ViewRequests.html Accept: text/html, */* Content-Type: application/x-www-form-urlencoded UA-CPU: x86 Accept-Encoding: gzip, deflate User-Agent: Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; .NET CLR 1.1.4322; .NET CLR 2.0.50727; .NET CLR 3.0.04506.30) Host: localhost:8084 Content-Length: 0 Connection: Keep-Alive Cache-Control: no-cache Cookie: JSESSIONID=05A26E33BA17C3725AA0366D6D646D37 Authorization: NTLM TlRMTVNTUAABAAAAB7IIogQABAAwAAAACAAIACgAAAAFASgKAAAAD0QzQjcyTDNKVFBNSQ==

view=20&page=0&rnd=1237223693715

Change History

comment:1 Changed 4 years ago by addyosmani

  • Status changed from new to closed
  • Resolution set to invalid

Incomplete test-case. Without being able to see what data-structures you're using behind this example (specifically when loading external content we need to have access to the URL so that we can investigate whether its the cause of the issue), we can only guess what it is that you're trying to achieve in your code snippet.

If you can re-submit your ticket with a complete test case we will be more than happy to re-investigate. Closing for now.

Note: See TracTickets for help on using tickets.