Bug Tracker

Modify

Ticket #4220 (closed bug: invalid)

Opened 5 years ago

Last modified 2 years ago

jquery Dialog crash in IE

Reported by: sachinkatkar Owned by:
Priority: major Milestone: 1.4
Component: unfiled Version: 1.3.2
Keywords: dialog Cc: skatkar@…
Blocking: Blocked by:

Description

Hi, I am using jquery dialog to display messages. As i have to show this confirmation messages depending upon my server side code. for e. g if record inserted successfully i ues Page.ClientScript.RegisterStartupScript() method. It works fine in mozilla firefox but while browsing same page in IE it shows me error saying that "Internet Explorer Cannot Open the Page". Here is my server side code

protected void Button1_Click(object sender, EventArgs e)

{

Page.ClientScript.RegisterStartupScript(this.GetType(), "showpp", "showpp();", true);

}

where showpopup() is my jscript method where i am calling jquery Dialog to display message. Here is my showpp() jscript function which is present in head tag of my aspx page.

<script type="text/javascript">

function showpp()

{

var vr=document.getElementById('dialog');

vr.style.display='block';

$('#dialog').dialog({Height:1000,

bgiframe: true,

modal: true,

buttons: {

Close: function() {

$(this).dialog('close');

}

},

overlay: {

opacity: 0.5,

background: "black"

}

});

}

'dialog' is the id of my div which i am showing in messages. it is invisible default. I make that visible first and then call $('#dialog').dialog() method.

Please help me out to solve this issue as few days are remaining to meet project's deadline.

Change History

comment:1 Changed 5 years ago by RavenRA

This is duplicate of ticket:4175

comment:2 Changed 5 years ago by dmethvin

  • Status changed from new to closed
  • Resolution set to invalid

This is not a jQuery core bug. Please use the jQuery forums or contact the author via the method they request. For jQuery UI plugins, please file a bug on  http://dev.jqueryui.com .

Please follow the  bug reporting guidlines and use  jsFiddle when providing test cases and demonstrations instead of pasting the code in the ticket.

View

Add a comment

Modify Ticket

Action
as closed
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.