Bug Tracker

Modify

Ticket #4142 (closed bug: fixed)

Opened 5 years ago

Last modified 5 years ago

the selector by attribute has a bug

Reported by: Do1Win2 Owned by: john
Priority: major Milestone: 1.3.2
Component: selector Version: 1.3.1
Keywords: Cc:
Blocking: Blocked by:

Description

$('div[name=321]')


as this attribute selector is novalid because of the name attribute

Change History

comment:1 Changed 5 years ago by dmethvin

What doctype are you using where a div element has a name attribute? If it's an XML document that should work. For (X)HTML documents jQuery uses getElementsByName which the W3C defines here:

 http://www.w3.org/TR/DOM-Level-2-HTML/html.html#ID-71555259

comment:2 Changed 5 years ago by dmethvin

  • Status changed from new to closed
  • Resolution set to fixed

Duplicate of #4081, should be fixed by [6082].

Please follow the  bug reporting guidlines and use  jsFiddle when providing test cases and demonstrations instead of pasting the code in the ticket.

View

Add a comment

Modify Ticket

Action
as closed
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.