Bug Tracker

Modify

Ticket #4112 (closed bug: fixed)

Opened 5 years ago

Last modified 4 years ago

Out of Memory Exception in IE with AJAX calls

Reported by: budigelli Owned by:
Priority: minor Milestone: 1.3.2
Component: ajax Version: 1.3.1
Keywords: ajax Cc: budigelli@…
Blocking: Blocked by:

Description

The change set 6027 for ajax.js has a change to 'windoweval?' from "eval" and causing "Out of Memory" exception in IE on a specific case for me.

I am curious what is the reason for this change. the only difference i could find between window.eval and eval is the following

 http://www.hedgerwow.com/360/bugs/eval.html

From the comments of this change set, it appears that the purpose is to get better compression than intended behavioral change. Note: we changed our local version of 1.3.1 to use "eval" just like in version 1.2.6 and everything works fine (with uncompressed version).

Thanks

Change History

comment:1 Changed 5 years ago by budigelli

'windoweval?' in the text is ' window [ " eval " ] ' without spaces...

comment:2 Changed 5 years ago by dmethvin

Can you provide a test case with the actual code that is causing the problem?

comment:3 Changed 5 years ago by dmethvin

  • Priority changed from critical to minor
  • Component changed from unfilled to ajax

comment:4 Changed 4 years ago by dmethvin

  • Status changed from new to closed
  • Resolution set to fixed

This was changed (and presumably fixed) in 1.4.

Please follow the  bug reporting guidlines and use  jsFiddle when providing test cases and demonstrations instead of pasting the code in the ticket.

View

Add a comment

Modify Ticket

Action
as closed
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.