Bug Tracker

Modify

Ticket #4058 (closed bug: fixed)

Opened 5 years ago

Last modified 5 years ago

Simple selector not working in 1.3.1 with webkit browsers

Reported by: ecentinela Owned by: john
Priority: critical Milestone: 1.3.2
Component: selector Version: 1.3.1
Keywords: chrome find selector Cc:
Blocking: Blocked by:

Description

Refer to this group thread.

Attachments

index.html Download (1.5 KB) - added by ecentinela 5 years ago.
chrome find selector
find-testcase.htm Download (717 bytes) - added by ricardobeat 5 years ago.
Short test-case

Change History

Changed 5 years ago by ecentinela

chrome find selector

Changed 5 years ago by ricardobeat

Short test-case

comment:2 Changed 5 years ago by ricardobeat

I reduced the test case.

The problem is the call to find() before adding the class. It's like the find() return is cached in some way. I happens only for class selectors, only with find() (children/filter work alright), and happens either using the cached container object or a new one.

Sizzle should be handling the query to querySelectorAll, but container[0].querySelectorAll('.selected') returns the expected results.

Hope that helps,

comment:3 Changed 5 years ago by ricardobeat

Forgot to add that this bug only happens if the target element already has a class defined, otherwise everything works fine.

comment:4 Changed 5 years ago by john

  • Status changed from new to closed
  • Resolution set to fixed

Fixed in SVN rev [6178].

comment:5 Changed 5 years ago by john

  • Priority changed from blocker to critical

Please follow the  bug reporting guidlines and use  jsFiddle when providing test cases and demonstrations instead of pasting the code in the ticket.

View

Add a comment

Modify Ticket

Action
as closed
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.