Bug Tracker

Modify

Ticket #3977 (closed bug: duplicate)

Opened 5 years ago

Last modified 5 years ago

WebKit - Empty Class Attributes using Context argument

Reported by: braddunbar Owned by: john
Priority: major Milestone: 1.3.2
Component: selector Version: 1.3.1
Keywords: class , context Cc:
Blocking: Blocked by:

Description

In Webkit (tested in Chrome v1.0.154.43 and Safari v3.2.1), selecting by class using the context variable yields incorrect results if other elements have an empty class attribute.

Verified to work correctly in Opera v9.63, Firefox 3.1b2 & IE8b2.

The attached test will eplain more clearly.

Attachments

bug.html Download (578 bytes) - added by braddunbar 5 years ago.
Using jQuery 1.3.1 rather than 1.3.0

Change History

Changed 5 years ago by braddunbar

Using jQuery 1.3.1 rather than 1.3.0

comment:1 Changed 5 years ago by john

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #3938.

Please follow the  bug reporting guidlines and use  jsFiddle when providing test cases and demonstrations instead of pasting the code in the ticket.

View

Add a comment

Modify Ticket

Action
as closed
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.