Bug Tracker

Ticket #3730 (closed bug: duplicate)

Opened 6 years ago

Last modified 6 years ago

BUG: input text element hover() in FF Firefox

Reported by: dazz Owned by:
Priority: major Milestone: 1.3
Component: unfiled Version: 1.2.6
Keywords: firefox hover input Cc:
Blocking: Blocked by:

Description

When you use hover() on an input text element in FF the result is very flaky. As you mouseover it seemingly randomly works correctly or not. (The mouseout event is not always (fired or caught)).

Change History

comment:1 Changed 6 years ago by dazz

Both the mouseover and mouseout parts of hover work sporadically.

comment:2 Changed 6 years ago by dmethvin

  • need changed from Review to Test Case

Hi, can you attach a simple test case?

comment:3 Changed 6 years ago by flesler

  • Owner flesler deleted

comment:4 Changed 6 years ago by sj_waterson

I am currently experiencing an issue that sounds similar. On my site, we have a horizontal menu bar near the top of the page. Hovering over the items in this top level navigation reveals a vertical second level of navigation that appears above the contents of the page, something like this:

  Menu 1.0  |  Menu 2.0  | Menu 3.0  | Menu 4.0
  -item 1.1
  -item 1.2 
  -item 1.3
  -item 1.4

This sub-menu should remain visible as long as the mouse remains inside the area of the menu item 1.0 or the submenu. Once the mouse leaves, it should go away - a typical sort of menu/sub-menu behavior. This seems to work just dandy in IE6, IE7, Safari, Chrome and Firefox AS LONG AS the page contains only text, images, links, etc. and not text input areas.

If, in FF2 and FF3 only (the other browsers are happy), the page contains some form elements (text areas and text input) and the user loses focus of the sub menu by exiting the sub menu while it is over the form element, the menu stays visible - as if the mouseout event is never fired. In order to get the menu to go away, the user must move their mouse back over the sub menu and then leave the sub menu on an area of the page where the sub menu is not covering a form element.

A long text description of something that would best be served by a movie or picture. I've just started playing with Jing, so maybe this will work:  http://screencast.com/t/TH2D2cdx81

Unfortunately, my site is behind a login and is rather icky to share, but I could work on creating an simpler example to see if I can provide a test case.

comment:5 Changed 6 years ago by bgrinstead

 http://jquery.nodnod.net/cases/195 Here is a test case. If you just move your mouse up and down the list of inputs that are touching each other, some of them seem to stick and not fire the mouseout event. It seems that it could be a similar problem that sj_waterson posted where the event is not firing when the mouse is over another input when the event should fire, since it seems to work fine in the inputs that are not adjacent to each other.

comment:6 Changed 6 years ago by dmethvin

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #3286 and #3935

Note: See TracTickets for help on using tickets.