Bug Tracker

Modify

Ticket #3721 (closed bug: invalid)

Opened 5 years ago

Last modified 5 years ago

[validate] Validation doesn't happen in Opera 9.5 when validation rules defined in class attr

Reported by: savamura Owned by: joern
Priority: major Milestone: 1.3
Component: plugin Version: 1.2.6
Keywords: validation plugin Cc: savamura
Blocking: Blocked by:

Description

Validation doesn't happen in Opera 9.5 when validation rules defined in class attribute. <input type="text" name="email" class="required" id="email" />

In FF and IE it works fine. If I set validation rules in rules object it works in Opera: $("#form").validate( {rules : {email : {required: true}} } ); So it's the only way to make it work in Opera.

Change History

comment:1 Changed 5 years ago by flesler

  • Cc savamura added
  • Owner changed from flesler to joern
  • Component changed from unfilled to plugin

comment:2 Changed 5 years ago by joern

  • Status changed from new to closed
  • Resolution set to invalid

Can't reproduce. Reading class-metadata works fine in my tests.

Please follow the  bug reporting guidlines and use  jsFiddle when providing test cases and demonstrations instead of pasting the code in the ticket.

View

Add a comment

Modify Ticket

Action
as closed
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.