Bug Tracker

Modify

Ticket #3587 (closed bug: duplicate)

Opened 5 years ago

Last modified 5 years ago

animate({height: 0}) causes incorrect height after animation is completed

Reported by: TNT Owned by:
Priority: major Milestone: 1.3
Component: effects Version: 1.2.6
Keywords: animate height Cc: TNT, flesler
Blocking: Blocked by:

Description

when i try this:

$('#div4').css({'width': 100, 'height': 100, 'border': '1px solid red'});

$('#div4').animate({height: 0}, 2000);

-> after animation is completed DIV has grow up to 21px height in IE6, in FF DIV have 0px height

<div id="div4"></div>

Attachments

index.htm Download (993 bytes) - added by TNT 5 years ago.
test html file

Change History

comment:1 Changed 5 years ago by flesler

  • Cc TNT, flesler added
  • need changed from Patch to Test Case

can you make a test case ? (html file)

Changed 5 years ago by TNT

test html file

comment:2 Changed 5 years ago by TNT

I'm added attachment test HTML file

comment:3 Changed 5 years ago by TNT

I'm fixing for me with this code:

$('#div3').animate({'height': '1px'}, 2000, function(){$(this).css({'overflow':'hidden', 'height': '0px', 'visibility': 'hidden'});});

and this working fine (for me). :)

comment:4 Changed 5 years ago by davidserduke

I believe this is a duplicate of #1726. Basically the doctype is malformed so the browser is in quirksmode and jQuery no longer supports quirksmode for animation and the like. Try fixing your doctype and see if that helps too.

comment:5 Changed 5 years ago by davidserduke

  • Status changed from new to closed
  • Resolution set to duplicate

Please follow the  bug reporting guidlines and use  jsFiddle when providing test cases and demonstrations instead of pasting the code in the ticket.

View

Add a comment

Modify Ticket

Action
as closed
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.