Bug Tracker

Modify

Ticket #3526 (closed bug: worksforme)

Opened 5 years ago

Last modified 2 years ago

validation bug (No validation with jquery.validate.js)

Reported by: Le Moustique Owned by: joern
Priority: major Milestone: 1.3
Component: plugin Version: 1.2.6
Keywords: validate Cc:
Blocking: Blocked by:

Description

Hello,

I found a bug inside your jquery validation. I created 1 example so you can see it.

Just go to this link online -->  http://users.telenet.be/Nobels/basic/index.html

or open zip in attach.

Do these steps to see the bug:

  • Push Demo button (modal popup will show)
  • You will find 2 textboxes inside modal popup.

Those 2 are added to the JQuery validation.

  • Push Login and you will see that the form is NOT valid. (so good so far)
  • Close modal popup (Upper right corner)
  • Push demo button again.
  • Push Login button again. --> you will see that there is no validation donne. and the form is submitted.

I can not find the cause of the problem.

Did i miss something ?

Please help me out because your feature is greate :-)

I you need more details just ask :-)

Mvg,

Kris Nobels

Attachments

badValidation.zip Download (30.8 KB) - added by Le Moustique 5 years ago.
Bug example to reproduce

Change History

Changed 5 years ago by Le Moustique

Bug example to reproduce

comment:1 Changed 5 years ago by flesler

  • Keywords validate added; validation removed
  • Owner changed from flesler to joern
  • Component changed from unfilled to plugin

comment:2 Changed 5 years ago by joern

  • Status changed from new to closed
  • Resolution set to worksforme

Looks like you have to initialize the validation when opening the modal dialog.

Also set debug:true to debug see the error thrown on submit.

Please follow the  bug reporting guidlines and use  jsFiddle when providing test cases and demonstrations instead of pasting the code in the ticket.

View

Add a comment

Modify Ticket

Action
as closed
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.