Bug Tracker

Ticket #3429 (closed bug: duplicate)

Opened 6 years ago

Last modified 6 years ago

Detecting of agent's version

Reported by: sms-send Owned by: flesler
Priority: major Milestone: 1.3
Component: core Version: 1.2.6
Keywords: Cc:
Blocking: Blocked by:

Description

jQuery.browser = {

version: (userAgent.match( /.+(?:rv|it|ra|ie)[\/: ]([\d.]+)/ )
[])[1],

... };

Please, replace ".+" with ".+?" to find real version (MSIE 7.0) in agents like this:

"Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; WebMoney Advisor; MRA 4.9 (build 01863); Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1) ; .NET CLR 2.0.50727; .NET CLR 3.0.04506.30; MEGAUPLOAD 2.0; InfoPath.2; .NET CLR 1.1.4322)"

Change History

comment:1 Changed 6 years ago by flesler

  • Status changed from new to assigned

Yes, we have quite many tickets on this. We need to do a lot of testing.

comment:2 Changed 6 years ago by flesler

  • Component changed from unfilled to core

comment:3 Changed 6 years ago by dmethvin

Duplicate of #2661

comment:4 Changed 6 years ago by dmethvin

  • Status changed from assigned to closed
  • Resolution set to duplicate
Note: See TracTickets for help on using tickets.