Bug Tracker

Ticket #3421 (closed bug: wontfix)

Opened 6 years ago

Last modified 4 years ago

fadeIn/fadeOut problem with font colors

Reported by: Taturana Owned by:
Priority: major Milestone: 1.3
Component: effects Version: 1.2.6
Keywords: fade color Cc: Taturana, flesler
Blocking: Blocked by:

Description

Hello,

I've tested the bug. In FF 3.0.

When you put a div or something with a colored font to fade in/out with fadeIn/fadeOut function the font blurs and gets green like "crazy colors" while fading.

The function with IE is perfect, the error is in Firefox only.

Please fix it the fast as possible or send me a response.

Attachments

WKPanel.zip Download (30.1 KB) - added by Taturana 6 years ago.
a simple html file containing the error

Change History

comment:1 Changed 6 years ago by flesler

  • Cc Taturana, flesler added
  • need changed from Patch to Test Case
  • Priority changed from blocker to major

Could you provide a test case ? a minimalistic html file with the requires html and js to reproduce the problem. Thanks.

comment:2 Changed 6 years ago by brandonZ

When you put a div or something with a colored font to fade in/out with fadeIn/fadeOut function the font blurs and gets green like "crazy colors" while fading.

The function with IE is perfect, the error is in Firefox only.

Please fix it the fast as possible or send me a response.

If you are referring to the anti-aliasing being weird in a Windows environment, that is a know issue with the way Windows applies ClearType. Know that changing the opacity of something may appear to affect its hue. However, I was completely unable to replicate/observe the changing of font colors while executing either the fadeIn or fadeOut method on an element containing colored text. I checked in Firefox (2 PC/Mac, 3 PC/Mac), Internet Explorer (6, 7, 8b), Opera (9.5), Google Chrome, and Safari (3 PC/Mac). If you can replicate your problem, please provide a link to a simple test page.

Changed 6 years ago by Taturana

a simple html file containing the error

comment:3 Changed 6 years ago by Taturana

You can also access the error page on my link  http://tatuserv.no-ip.info/Projects/WorkanaCP/WKPanel/lol.html

entering with user: root pass: test

comment:4 follow-up: ↓ 5 Changed 6 years ago by Taturana

Yes, I tested here and it's due to ClearType from windows vista, there's something I can do (in jquery) to fix that for people those have clearType enabled?

Thanks

comment:5 in reply to: ↑ 4 Changed 6 years ago by brandonZ

Replying to Taturana:

Yes, I tested here and it's due to ClearType from windows vista, there's something I can do (in jquery) to fix that for people those have clearType enabled?

Thanks

Unfortunately, there isn't much we can do about that. However, Internet Explorer seems to use the the background color of the text container as a matte when applying anti-aliasing. In summary, setting the css background-color property may help.

comment:6 Changed 6 years ago by Taturana

Really thank you it helped me alot.

Then,

The definitive fix for ClearType opacity problem is: Set a background color to parent object.

I hope it helps other people...

Thanks all

comment:7 Changed 6 years ago by flesler

  • Status changed from new to closed
  • Resolution set to wontfix

comment:8 Changed 4 years ago by Partizan

Tanturana, actually you need to set the background on the elements that you're fading in/out and not just the parent object. Initially, I didn't have background-color set on the links displayed through animation and it didn't work, but then I set explicit background on them and they work!

Note: See TracTickets for help on using tickets.