Bug Tracker

Ticket #3342 (closed feature: wontfix)

Opened 6 years ago

Last modified 2 years ago

Support POST for cross-domain AJAX requests

Reported by: HonestQiao Owned by: HonestQiao
Priority: low Milestone: 1.5
Component: ajax Version: 1.4.4
Keywords: CORS XMLHttpRequest XDomainRequest Cc: snover
Blocking: Blocked by: #7195

Description

Cross-Domain Ajax POST Patch for jQuery 1.2.5

  1. function:

jQuery.Ajax can post to cross-domain

  1. install:

files:patch_for_jQuery 1.2.5.txt index.html ajax_post.php modify 'site.com' to you domain.

  1. visit index.html

Attachments

cross-domain_ajax_post.zip Download (3.3 KB) - added by HonestQiao 6 years ago.
Patch file

Change History

Changed 6 years ago by HonestQiao

Patch file

comment:1 Changed 6 years ago by flesler

  • Cc HonestQiao, flesler added
  • need changed from Patch to Review
  • Milestone changed from 1.2.5 to 1.3

Ok, thanks for all the data. So you propose to create an iframe, add a form, include as many input elements as POST fields and submit it.

IMO it may work, but seems like an aggressive approach to do such a thing. Adding iframes can cause unexpected behaviors.

I'll ask around, thanks.

comment:6 Changed 4 years ago by rwaldron

  • Priority changed from major to low
  • Status changed from new to closed
  • Resolution set to wontfix

This patch is way out of date.

comment:7 Changed 4 years ago by rwaldron

  • Status changed from closed to reopened
  • Resolution wontfix deleted
  • Milestone 1.3 deleted

comment:8 Changed 4 years ago by rwaldron

  • Cc snover added; HonestQiao, flesler removed
  • Owner set to HonestQiao
  • Status changed from reopened to pending

Please provide an updated patch for this request.

comment:9 Changed 4 years ago by snover

  • Keywords CORS XMLHttpRequest XDomainRequest added; Croos-Domain POST removed
  • Status changed from pending to open
  • Version changed from 1.2.5 to 1.4.3
  • Summary changed from Cross-Domain Ajax POST Patch for jQuery 1.2.5 to Support POST for cross-domain AJAX requests

comment:10 Changed 4 years ago by snover

  • Blocked by 7195 added

comment:11 Changed 4 years ago by rwaldron

  • Keywords CORS,XMLHttpRequest,XDomainRequest,ajaxrewrite added; CORS XMLHttpRequest XDomainRequest removed

comment:12 Changed 4 years ago by snover

  • Keywords CORS XMLHttpRequest XDomainRequest ajaxrewrite added; CORS,XMLHttpRequest,XDomainRequest,ajaxrewrite removed

comment:13 Changed 4 years ago by jaubourg

You can already do that on browsers that support cors (jQuery.support.cors) with no iframe hacks. With the new architecture, adding an iframe based transport shouldn't be an issue but clearly is best suited for a plugin imo.

comment:14 Changed 4 years ago by jitter

  • Keywords ajaxrewrite removed
  • Status changed from open to closed
  • Version changed from 1.4.3 to 1.4.4
  • Resolution set to wontfix
  • Milestone set to 1.5

The new ajax rewrite makes it easy to write a plugin which provides a transport to handle cross-domain request cross-browser. For the moment being this won't be done in core directly and thus is best suited for a plugin.

comment:15 Changed 4 years ago by jitter

#8283 is a duplicate of this ticket.

Note: See TracTickets for help on using tickets.