Bug Tracker

Modify

Ticket #3341 (closed bug: duplicate)

Opened 6 years ago

Last modified 5 years ago

Offset of positioned fixed elements buggy in Safari

Reported by: dtetto Owned by: brandon
Priority: minor Milestone: 1.3
Component: offset Version: 1.2.6
Keywords: offset,safari,fixed,position Cc:
Blocking: Blocked by:

Description

In Safari 3.1 the offset is misreported for position:fixed elements inside any positioned element. The offset of the container element plus the offset from the document is returned, rather than just the offset from the document. This problem still exists in the latest Webkit nightlies. The bug does not occur in Firefox 2 or 3, nor IE7 (not applicable in IE6, which support fixed positioning).

I've demonstrated this in a testcase here:  http://www.babywhale.net/offset/

Change History

comment:1 Changed 5 years ago by brandon

  • Status changed from new to closed
  • Resolution set to duplicate

duplicate of #4263

Please follow the  bug reporting guidlines and use  jsFiddle when providing test cases and demonstrations instead of pasting the code in the ticket.

View

Add a comment

Modify Ticket

Action
as closed
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.