Bug Tracker

Ticket #3323 (closed bug: duplicate)

Opened 6 years ago

Last modified 4 years ago

jsquery .hide changes the font of the text in Internet Explorer

Reported by: sss8969 Owned by:
Priority: minor Milestone: 1.3
Component: effects Version: 1.2.6
Keywords: .hide .show Cc: sss8969, flesler
Blocking: Blocked by:

Description

In Internet Explorer 7, it appears that the .hide method changes the font or style of text as it is hiding it. When the text is redisplayed using .show, the text has a different font, or at least appears to be "less bold".

I have not extensively tested this issue, but it does not appear to happen in Firefox 2.0.0.16.

I've been able to reproduce the problem using an example from the jquery web site,  http://docs.jquery.com/Effects/hide#speedcallback. I've also attached a sample file. The problem seems to be more apparent with smaller text sizes.

Attachments

jqueryShowHideSample.htm Download (1.1 KB) - added by sss8969 6 years ago.
Sample html showing the font change behavior. Notice as each word is hidden, that the font changes to a less bold, less smooth version. When the text is redisplayed, it stays that way.

Change History

Changed 6 years ago by sss8969

Sample html showing the font change behavior. Notice as each word is hidden, that the font changes to a less bold, less smooth version. When the text is redisplayed, it stays that way.

comment:1 Changed 6 years ago by flesler

  • Cc sss8969, flesler added
  • Component changed from core to fx

comment:2 Changed 6 years ago by dmethvin

  • need changed from Review to Patch
  • Owner set to dmethvin
  • Status changed from new to assigned

This is due to IE/Windows ClearType font smoothing. I guess the fix is to remove the filter attribute if the opacity is set to 1.0?

 http://blog.bmn.name/2008/03/jquery-fadeinfadeout-ie-cleartype-glitch/

comment:3 Changed 6 years ago by dmethvin

  • Owner dmethvin deleted
  • Status changed from assigned to new

comment:4 Changed 4 years ago by dmethvin

  • Status changed from new to closed
  • Resolution set to duplicate

Dup of #2457.

Note: See TracTickets for help on using tickets.