Bug Tracker

Ticket #3211 (closed bug: wontfix)

Opened 6 years ago

Last modified 4 years ago

Test Version : Safari Version 2.0.4 (419.3) / MacOsX 10.4.10 / jQuery126

Reported by: fanou Owned by: flesler
Priority: major Milestone: 1.3
Component: core Version: 1.2.6
Keywords: Cc:
Blocking: Blocked by:

Description

Hi, i've discovered a really strange & annoying bug relating to Safari and jQ 126 (v.123 seems to be more stable with this browser version than is v.126. As an example try to consult the 'learningjquery.com' site with this browser and it crash immediately - if i'm not mistaken it uses v.126 - rather bad for the newcomers!)

Test case : HTML <div id="testCase"><p class="paraTest"></p></div>

JQUERY you see the space between the 2 span's - it seems that Safari doesn't like that & for fun crash! $('.paraTest').html('<span>span001</span> <span>span002</span>'); if you avoid the space it works wonderfully $('.paraTest').html('<span>span001</span><span>span002</span>');

Hope it can help and by the way Thanks so much for your hard work on this fascinating library

Stéphan / France

Change History

comment:1 Changed 6 years ago by flesler

  • Owner set to flesler

comment:2 Changed 6 years ago by fanou

I found some more things that might interest you: Looks like Safari doesn't like at all fragments of text that's not wrapped in a tag (something surely related to the space bug!!!)

IF YOU EXECUTE SOMETHING LIKE THIS :

$('<span>').html('Cliquer sur la boite pour connaitre sa Clr!').appendTo('.resClr');it crash

$('<span>').html('Cliquer sur la <em>boite pour connaitre sa Clr</em>!').appendTo('.resClr');it crash

$('<span>').html('<em>Cliquer sur la boite pour connaitre sa Clr!</em>').appendTo('.resClr');it works

it means that you can't insert a fragment in another tag if is not itself surrounded by one.

YOU CAN REPRODUCE THIS WITH .APPEND('fragments') TOO:

$('.resClr').append('<em>Cliquer sur la boite</em> pour connaitre sa Clr!');it crash even if the tag is first

$('.resClr').append('<em>Cliquer sur la boite pour connaitre sa Clr!</em>');it works

Hope it can be fixed soon - Stéphan

comment:3 in reply to: ↑ description Changed 6 years ago by eric258

This is related to bug #3397, which contains a patch that fixes the problem temporarily.

comment:4 Changed 4 years ago by dmethvin

  • Status changed from new to closed
  • Resolution set to wontfix

Safari 2 isn't supported anymore.

Note: See TracTickets for help on using tickets.