Bug Tracker

Modify

Ticket #3093 (closed bug: duplicate)

Opened 6 years ago

Last modified 5 years ago

Attribute selector doesn't work right with style

Reported by: ajpiano Owned by:
Priority: major Milestone: 1.3
Component: core Version: 1.2.6
Keywords: attribute selector style Cc:
Blocking: Blocked by:

Description

One might assume that one would use $("[style]") to find all elements with an inline style attribute, which isn't exactly how it works.

[$("div").length,$("div[style]").length,$("div[class]").length,$("[style]").length];

// returned [48,48,32,959] in a random sample document.

Seems confusing.

Change History

comment:1 Changed 6 years ago by flesler

  • need changed from Review to Test Case

Can you please provide a test case ? that is, a small html file with the minimum html/css/js necessary to reproduce the problem. Also, please specify what browsers are you trying this on. Thanks

comment:2 Changed 5 years ago by dmethvin

  • Status changed from new to closed
  • Resolution set to duplicate

This is a duplicate of #3399; the problem is that .attr("style") returns the style property/expando and not the style attribute.

Please follow the  bug reporting guidlines and use  jsFiddle when providing test cases and demonstrations instead of pasting the code in the ticket.

View

Add a comment

Modify Ticket

Action
as closed
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.