Bug Tracker

Modify

Ticket #2792 (closed bug: invalid)

Opened 6 years ago

Last modified 5 years ago

accordion right span not inserting correct

Reported by: sosensible Owned by: joern
Priority: minor Milestone: 1.2.4
Component: ui Version: 1.2.3
Keywords: accordion Cc:
Blocking: Blocked by:

Description

The right accordion span is inserting inside the <a/> tag but the left is working correctly and puts the span before the <a/> set. (Same in IE and FF on Vista)

Change History

comment:1 Changed 6 years ago by joern

  • Status changed from new to closed
  • Resolution set to invalid

That isn't an error, but required for themeing with CSS. See  http://dev.jquery.com/view/trunk/themes/flora/flora.accordion.css for reference theme.

comment:2 Changed 6 years ago by sosensible

  • Status changed from closed to reopened
  • Resolution invalid deleted

Note: it was putting tags like this...

<span class="ui-accordion-left"/>
<span class="ui-accordion-left"/>
<a class="ui-accordion-link ui-accordion-header selected" href="#" tabindex="0">
Test 1
<span class="ui-accordion-right"/>
<span class="ui-accordion-right"/>
</a>


There were even some cases where I have seen three tag sets. The leading (left) doesn't visually appear to show either to us.



OK... it may not be an error but in FF it sticks the accordion-right in the upper right corner of the browser. And the left as I said is just not visible.

IT'S broke! :) I am online now at least if screen sharing to see the issue is helpful.

comment:3 Changed 6 years ago by sosensible

It's worse in IE BTW... IE shows an extra line with each accordion title bar.

comment:4 Changed 6 years ago by sosensible

You "DELETED" my issue?

comment:5 Changed 6 years ago by paul

  • Owner changed from paul to joern
  • Priority changed from major to minor
  • Status changed from reopened to new

comment:6 Changed 5 years ago by joern

  • Status changed from new to closed
  • Resolution set to invalid

Accordion is now part of jQuery UI

Please follow the  bug reporting guidlines and use  jsFiddle when providing test cases and demonstrations instead of pasting the code in the ticket.

View

Add a comment

Modify Ticket

Action
as closed
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.