Bug Tracker

Modify

Ticket #2761 (closed bug: invalid)

Opened 6 years ago

Last modified 2 years ago

[autocomplete] up/down arrow in list causes cursor to move in FF2 on a Mac

Reported by: zelph Owned by: joern
Priority: minor Milestone: 1.2.4
Component: plugin Version: 1.2.3
Keywords: autocomplete Cc:
Blocking: Blocked by:

Description (last modified by joern) (diff)

In FireFox 2.0 on a Mac, when you click up (or down) when there is a list showing the cursor moves to the front(back) of the input field. If for whatever reason the user wants to continue to type they are now at the start of the field instead of the end.

Steps to duplicate:

- In the "Single City" demo on the official page, type "saint".
- Press down one or more times, and then press up
- Type space or any additional character. They will be at the front of the string.

Expected result:

  • Typing should continue at the end of the string.

Change History

comment:1 Changed 6 years ago by joern

  • Owner set to joern

comment:2 Changed 6 years ago by joern

  • Description modified (diff)

Not sure yet whats causing this. For key up/down events, event.preventDefault() is called, well, to prevent the default. Can't reproduce it due to lack of a Mac.

comment:3 follow-up: ↓ 4 Changed 6 years ago by aheimlich

Well, I can confirm that the issue exists. Unfortunately, I can't think of a fix for it, ATM :(.

comment:4 in reply to: ↑ 3 Changed 6 years ago by aheimlich

Replying to aheimlich:

Well, I can confirm that the issue exists. Unfortunately, I can't think of a fix for it, ATM :(.

I can also confirm that this issue is limited to Firefox 2 on Mac OS. Firefox 3 Beta 5 does not exhibit this issue, nor does Safari 3.1.1.

comment:5 Changed 6 years ago by zelph

I tracked this down to be an issue with the autocomplete attribute that is set to off with the plugin. It does appear to be a browser bug as it can be duplicated with flat html input fields with and without the autocomplete attribute, so not much we can do about that.

I also confirm that it is fixed in FF3 RC 1.

comment:6 Changed 5 years ago by joern

  • Status changed from new to closed
  • Resolution set to invalid

The autocomplete plugin is now developed under the jQuery UI umbrella. Reopen a ticket there ( http://dev.jqueryui.com/) or participate on the planning wiki ( http://wiki.jqueryui.com/Autocomplete) if appropiate.

Also there doesn't seem to be a solution to this particular problem.

Please follow the  bug reporting guidlines and use  jsFiddle when providing test cases and demonstrations instead of pasting the code in the ticket.

View

Add a comment

Modify Ticket

Action
as closed
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.