Bug Tracker

Modify

Ticket #2755 (closed bug: wontfix)

Opened 6 years ago

Last modified 16 months ago

Update of the <title> tag

Reported by: azrail Owned by:
Priority: low Milestone:
Component: manipulation Version: 1.2.3
Keywords: Cc:
Blocking: Blocked by:

Description

I've noticed something a bit strange between FF2 and Safari. I am not sure if this is a jQuery bug, or a difference in how browsers work.

However, I have the following code to update the document.title portion for the browser.

if (document.title != $("title").text()+" "+owner.username+"-"+ticket.t_id) {
    document.title = $("title").text()+" "+owner.username+"-"+ticket.t_id;
}

In FF when I alert $("title") I get the same "default" title I have in my HTML. However, when using Safari, the $("title") variable changes with each time I update the document.title.

Change History

comment:1 Changed 6 years ago by davidserduke

  • Status changed from new to closed
  • Resolution set to wontfix

Unfortunately I can't find the link/ticket but I believe I've seen this question before. The result iirc was a general sentiment that there would be too much code necessary to handle this in jquery and it was unnecessary since document.title pretty much works find in all browsers. Thus $("title") wasn't worth the performance and size hits to fix it.

If you feel differently feel free to reopen the ticket with your thoughts.

Version 0, edited 6 years ago by davidserduke (next)

comment:2 Changed 3 years ago by jitter

#7025 is a duplicate of this ticket.

comment:3 Changed 3 years ago by jitter

#5881 is a duplicate of this ticket.

comment:4 Changed 3 years ago by jitter

#5005 is a duplicate of this ticket.

comment:5 Changed 3 years ago by jitter

#4548 is a duplicate of this ticket.

comment:6 Changed 3 years ago by jitter

#7339 is a duplicate of this ticket.

comment:7 Changed 3 years ago by jitter

  • Priority changed from minor to low
  • Component changed from core to manipulation
  • Milestone 1.2.4 deleted

comment:8 Changed 3 years ago by jitter

#8312 is a duplicate of this ticket.

comment:9 Changed 3 years ago by jitter

#7825 is a duplicate of this ticket.

comment:10 Changed 3 years ago by jitter

#7250 is a duplicate of this ticket.

comment:11 Changed 3 years ago by jitter

#6899 is a duplicate of this ticket.

comment:12 Changed 3 years ago by jitter

#5489 is a duplicate of this ticket.

comment:13 Changed 3 years ago by ajpiano

#8375 is a duplicate of this ticket.

comment:14 Changed 3 years ago by dmethvin

#9761 is a duplicate of this ticket.

comment:15 Changed 2 years ago by rwaldron

#10674 is a duplicate of this ticket.

comment:16 Changed 2 years ago by timmywil

#10709 is a duplicate of this ticket.

comment:17 Changed 2 years ago by dmethvin

#11320 is a duplicate of this ticket.

comment:18 Changed 2 years ago by addyosmani

#11333 is a duplicate of this ticket.

comment:19 Changed 16 months ago by dmethvin

#13165 is a duplicate of this ticket.

Please follow the  bug reporting guidlines and use  jsFiddle when providing test cases and demonstrations instead of pasting the code in the ticket.

View

Add a comment

Modify Ticket

Action
as closed
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.