Bug Tracker

Modify

Ticket #2547 (closed bug: invalid)

Opened 6 years ago

Last modified 4 years ago

Draggable bugs in IE and Firefox

Reported by: hecurb Owned by: braeker
Priority: major Milestone: 1.2.4
Component: ui Version: 1.2.3
Keywords: Cc:
Blocking: Blocked by:

Description

I recently implemented the UI dialog component and it works great. However, in the process I found two issues.

  1. Using IE, if there is a vertical scroll bar and I am not at the top of the page, the draggable function does not work properly and it jumps upward the same amount of height as the scroll height. I was able to put a temp fix for this in my app by commenting out a few lines of code in draggable.js.
  1. Using Firefox, if I am at the bottom of the page with a vertical scrollbar and I open the dialog for the first time, the entire page flickers before the dialog shows up.

I am not sure if there are already bugs opened for these. I was able to reproduce these two issues using the demos on your site as well.

Hope these helps!

Change History

comment:1 Changed 6 years ago by hecurb

PS: I am using 1.5 version of jquery UI

comment:2 Changed 6 years ago by paul

  • Owner changed from paul to braeker

comment:3 Changed 6 years ago by braeker

I cannot reproduce this bug, could you try to record a video or show me how reproduce it?

cheers, Eduardo

comment:4 Changed 6 years ago by paul

  • Status changed from new to closed
  • Resolution set to worksforme

comment:5 Changed 5 years ago by zeguizmo

  • Status changed from closed to reopened
  • Resolution worksforme deleted

Hi I can reproduce this bug in my application. This is very annoying because the draggable behaviour is totally unusable.

Here is a video showing the bug in action :

 http://www.dubuscyril.com/jquerybug/out.html

In the first part I use the .draggable() function with the scrollbar at the top of the page, it works perfectly, and in the second part I show you the bug.

I use the latest version of jQuery and the latest ui.draggable package. (not the dialog, just draggable)

I hope to hear from you soon because I can't fix it alone,

Thanks a lot,

Guizmo

comment:6 Changed 4 years ago by john

  • Status changed from reopened to closed
  • Resolution set to invalid

Please follow the  bug reporting guidlines and use  jsFiddle when providing test cases and demonstrations instead of pasting the code in the ticket.

View

Add a comment

Modify Ticket

Action
as closed
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.