Bug Tracker

Modify

Ticket #2533 (closed bug: worksforme)

Opened 6 years ago

Last modified 2 years ago

datepicker disable/enable focus bug

Reported by: mnichols Owned by: iMarc
Priority: major Milestone: 1.2.4
Component: ui Version: 1.2.3
Keywords: datepicker focus disable enable bug Cc:
Blocking: Blocked by:

Description

When you disable an datepicker and then enable it again, the focus event is not fired because setting 'disabled' on an element makes this handler invalid (Firefox and IE...not sure about others). The fix is to reattach the focus event on $target. To test, start with datepicker disabled, then enable, then try to use. You get an js error. See patch please.

Attachments

uidatepicker.enable.reattachfocus.patch Download (468 bytes) - added by mnichols 6 years ago.
datepicker focus reattachment

Change History

Changed 6 years ago by mnichols

datepicker focus reattachment

comment:1 Changed 6 years ago by paul

  • Owner changed from paul to iMarc

comment:2 Changed 6 years ago by paul

  • Priority changed from critical to major

comment:3 Changed 6 years ago by paul

  • Status changed from new to closed
  • Resolution set to worksforme

I couldn't reproduce this issue anymore.

Please follow the  bug reporting guidlines and use  jsFiddle when providing test cases and demonstrations instead of pasting the code in the ticket.

View

Add a comment

Modify Ticket

Action
as closed
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.