Bug Tracker

Modify

Ticket #2462 (closed bug: duplicate)

Opened 6 years ago

Last modified 5 years ago

backgroundPosition propertie

Reported by: ragamo Owned by:
Priority: major Milestone: 1.2.4
Component: core Version: 1.2.2
Keywords: Cc:
Blocking: Blocked by:

Description

.css({ backgroundPosition: ... doesn't work!

Change History

comment:1 follow-up: ↓ 2 Changed 6 years ago by flesler

It is working for me, do you have a test case ? at least tell us what browser/OS are you using and how are you setting the background position, and why do you say it doesn't work ? you don't see the change visually ? or something else.

comment:2 in reply to: ↑ 1 Changed 6 years ago by ragamo

Replying to flesler:

It is working for me, do you have a test case ? at least tell us what browser/OS are you using and how are you setting the background position, and why do you say it doesn't work ? you don't see the change visually ? or something else.

Doh! Yes it is working! no bug here! xD Seems i have commited an human error xD

Close this please

comment:3 Changed 6 years ago by davidserduke

  • Status changed from new to closed
  • Resolution set to worksforme

Closed on request of author.

comment:4 Changed 6 years ago by kswedberg

  • Status changed from closed to reopened
  • Resolution worksforme deleted

Hi Ariel, I'm reopening this ticket because there is a discrepancy between browsers:

IE6 and IE7 return undefined for css('backgroundPosition') but return correct results for css('backgroundPositionX') and css('backgroundPositionY').

FF3 returns correct results for css('backgroundPosition') but returns empty string for css('backgroundPositionX') and css('backgroundPositionY').

Safari3 returns correct results for all three.

Here is a test page:  http://test.learningjquery.com/background-position.html

comment:5 Changed 5 years ago by sauy7

Test cases and a potential fix here:  http://heighes.com/tests/jquery/

comment:6 Changed 5 years ago by moneal

FF2 only seems to work if it has been set with jQuery. Not if its been set with a external style sheet.

comment:7 Changed 5 years ago by brandon

  • Status changed from reopened to closed
  • Resolution set to duplicate

duplicate of #4295

Please follow the  bug reporting guidlines and use  jsFiddle when providing test cases and demonstrations instead of pasting the code in the ticket.

View

Add a comment

Modify Ticket

Action
as closed
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.