Bug Tracker

Modify

Ticket #2303 (closed bug: fixed)

Opened 6 years ago

Last modified 5 years ago

Cannot build custom reports in Trac

Reported by: c_t Owned by:
Priority: major Milestone: 1.3
Component: site Version: 1.2.6
Keywords: Cc:
Blocking: Blocked by:

Description

How to Reproduce

While doing a GET operation on /query, Trac issued an internal error.

This happens, whenever I try to generate a custom query. No matter whether I'm logged in or not.

Request parameters:

{'status': [u'new', u'assigned', u'reopened', u'closed'], 'component': u'ui', 'order': u'priority'}

System Information

Trac 0.11dev-r5354
Python 2.3.4 (#1, Oct 11 2006, 06:18:43)
[GCC 3.4.6 20060404 (Red Hat 3.4.6-3)]
setuptools 0.6c5
MySQL server: "5.0.27-log", client: "5.0.27", thread-safe: 0
MySQLdb 1.2.2
Genshi 0.4
Subversion 1.4.3 (r23084)

Python Traceback

Traceback (most recent call last):
  File "/usr/lib/python2.3/site-packages/Trac-0.11dev_r5354-py2.3.egg/trac/web/main.py", line 429, in dispatch_request
    dispatcher.dispatch(req)
  File "/usr/lib/python2.3/site-packages/Trac-0.11dev_r5354-py2.3.egg/trac/web/main.py", line 234, in dispatch
    req.session.save()
  File "/usr/lib/python2.3/site-packages/Trac-0.11dev_r5354-py2.3.egg/trac/web/session.py", line 175, in save
    (self.sid, self.last_visit, authenticated))
  File "/usr/lib/python2.3/site-packages/Trac-0.11dev_r5354-py2.3.egg/trac/db/util.py", line 50, in execute
    return self.cursor.execute(sql_escape_percent(sql), args)
  File "/usr/lib/python2.3/site-packages/Trac-0.11dev_r5354-py2.3.egg/trac/db/util.py", line 50, in execute
    return self.cursor.execute(sql_escape_percent(sql), args)
  File "build/bdist.linux-i686/egg/MySQLdb/cursors.py", line 166, in execute
  File "build/bdist.linux-i686/egg/MySQLdb/connections.py", line 35, in defaulterrorhandler
IntegrityError: (1062, "Duplicate entry '87bc48ae51e535b-0-0' for key 1")

Change History

comment:1 Changed 6 years ago by c_t

Oh, I'm so sorry that I didn't check the existing reports before. This is most probably a duplicate of #2222, #2058 and #2243 .

comment:2 Changed 5 years ago by john

  • Status changed from new to closed
  • Version changed from 1.2.2 to 1.2.6
  • Resolution set to fixed
  • Milestone changed from 1.2.3 to 1.3

This should be fixed now.

Please follow the  bug reporting guidlines and use  jsFiddle when providing test cases and demonstrations instead of pasting the code in the ticket.

View

Add a comment

Modify Ticket

Action
as closed
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.