Bug Tracker

Ticket #2210 (closed bug: wontfix)

Opened 7 years ago

Last modified 6 years ago

problem with safari and xhtml

Reported by: elvan49 Owned by: flesler
Priority: trivial Milestone: 1.2.4
Component: core Version: 1.2.2
Keywords: Cc:
Blocking: Blocked by:

Description

i've built a site with php/mysql and jquery. In safari some page display a jquery function because of the tag br and img (line 775). My tags were in the xhtml format (<br/>) and this fact created a bug. I've added a control in the jquery library to fix this bug :

if ( typeof arg == "string" ) {
				if ( !jQuery.browser.safari ){
					// Fix "XHTML"-style tags in all browsers
					arg = arg.replace(/(<(\w+)[^>]*?)\/>/g, function(m, all, tag){
						return tag.match(/^(abbr|br|col|img|input|link|meta|param|hr|area)$/i)? m : all+"></"+tag+">";
					});
				}

But i'm sure that it's not acceptable... Sorry for my poor english ! All of the problem is related there :  http://www.developpez.net/forums/showthread.php?t=477647

Change History

comment:1 Changed 7 years ago by joern

  • Owner changed from joern to david
  • Component changed from web to core

comment:2 Changed 6 years ago by flesler

  • need changed from Review to Test Case
  • Milestone changed from 1.2.3 to 1.2.4

Line 775 where ?

Could you provide a test case ? that is, an html file with the style and js used. Thanks

comment:3 Changed 6 years ago by flesler

  • Owner changed from david to flesler
  • Status changed from new to assigned

Same as #2194. Could you provide the exact Safari 2 version you're using ?

comment:4 Changed 6 years ago by flesler

  • Status changed from assigned to closed
  • Resolution set to wontfix

Ok, found the version and the problem.

Same as #2035.

Note: See TracTickets for help on using tickets.