Bug Tracker

Modify

Ticket #2184 (closed bug: fixed)

Opened 6 years ago

Last modified 2 years ago

clone won't work with THEAD, TFOOT, TBODY, TR and TD in MSIE

Reported by: kowcik Owned by:
Priority: major Milestone: 1.2.3
Component: core Version: 1.2.2
Keywords: Cc:
Blocking: Blocked by:

Description

Beacuse clone uses innerHTML if the detected browser is MS Internet Explorer, cloning won't work with these nodes. See attached test case.

Attachments

clone.html Download (1.1 KB) - added by kowcik 6 years ago.
Script will attempt to clone table elements using jQuery methods and native DOM. Results will be alerted for comparison.
2184.diff Download (1.8 KB) - added by davidserduke 6 years ago.
possible patch
fix-for-1.2.2-clone.diff Download (1.4 KB) - added by davojan 6 years ago.
Another possible solution. It doesn't use clean() and should be faster, but it's bigger.

Change History

Changed 6 years ago by kowcik

Script will attempt to clone table elements using jQuery methods and native DOM. Results will be alerted for comparison.

comment:1 Changed 6 years ago by kowcik

I've just checked with previously reported bugs, it is a duplicate of this bug:  http://dev.jquery.com/ticket/2169, but my test-case is more extensive. I've went thru these test with 1.2.1 and all tested elements worked , so this is a regression.

Changed 6 years ago by davidserduke

possible patch

comment:2 Changed 6 years ago by davidserduke

See also #2169 which has more information.

Changed 6 years ago by davojan

Another possible solution. It doesn't use clean() and should be faster, but it's bigger.

comment:3 Changed 6 years ago by davidserduke

Someone told me that <option> also is having problems. I'll check with John and Brandon to get their thoughts.

comment:4 Changed 6 years ago by davidserduke

  • Status changed from new to closed
  • Resolution set to fixed

Fixed in [4513].

Please follow the  bug reporting guidlines and use  jsFiddle when providing test cases and demonstrations instead of pasting the code in the ticket.

View

Add a comment

Modify Ticket

Action
as closed
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.