Bug Tracker

Ticket #2143 (closed bug: fixed)

Opened 7 years ago

Last modified 7 years ago

Major UI issues with IE6 & IE7

Reported by: rekabis Owned by: paul
Priority: critical Milestone: 1.2.2
Component: ui Version: 1.2.1
Keywords: IE6, IE7 Cc:
Blocking: Blocked by:

Description

Granted, these issues are with IE on Windows XP 64-bit running under VMware, but I normally don’t deal with Windows systems, except to test sites with IE. I would expect the same issues to occur under a bare metal install of XP 32-bit.

All issues are with both IE6 and IE7, and are triggered from the UI examples page ( http://docs.jquery.com/UI/). I have the Microsoft Script Debugger, which points out where the error occurred.

Draggables - upon begin of drag, after click.

Line: 2042
Error: Object Expected
File: jquery-latest.js
Content: event.preventDefault();
Notes: same error occurs again, but only once again, after you dismiss the dialog box and mouseover the area in which the box can be moved (the mouse does not need to move over the box in order to trigger the error a second time).

Droppables - same error as Draggables. As such, I was unable to test for the actual dropping ability, since the box was actually unable to be dragged that far before the error dialog box appeared.

Sortables - same error as Draggables, but I was able to make the items "wiggle around". I suspect this "wiggling" was due to some physics scripting that responds to movement and provides inertia and friction to objects in motion (I don’t know enough about jQuery to be definitive). Because the error occurred on drag, I was unable to test the sorting capability of the script. The second error message did *not* occur in this test.

Selectables - a strange one, this. Both error messages occurred again, but I was able to select individual items if I drew a box really fast *inside* the item’s box/area (~60% success rate). Clicking on the item didn’t work. Selecting multiple items and/or drawing a box *outside* of items was not possible due to the two JS errors.

Resizables - same two JS errors; no ability to resize at all, in any direction.

Accordion - works very nice. No errors found in either browser.

Datepicker v3.2 - no response whatsoever, either in results or in errors. Clicking inside the form fields produced no response of any kind.

Dialog - same two JS errors; no ability to resize in any direction, no ability to move dialog box.

Slider - a *very interesting* situation: actually trying to grab and move the slider produces the two JS errors, but clicking on another part of the slider’s bar caused the slider to jump to that point without any errors at all. Clearly, the slider itself works, but the drag-and-drop portion does not.

Tablesorter - no issues at all, a very well functioning script.

Tabs - no issues.

Tabs Extensions - no issues. Rotation stopped when a tab was clicked on, as expected.

Shadow - *appears* to function (need a bigger/darker shadow in that example, tho; I first thought that there was no shadow).

Magnifier - no issues, but first image not linked properly (does not show up).


Conclusion

Of all the examples viewed, the error occurred primarily when the object in question was moved/dragged. Therefore, I believe that there is just one bug, and that it exists in the handler for the dragging script. If this single bug was fixed, I am confident that all the examples above would function properly.

Change History

comment:1 Changed 7 years ago by kbwood

For datepicker - I think the problem is in our (mis)use of the APIExample template. Is there any documentation on how to use these anywhere? On what parameters are available/expected?

comment:2 Changed 7 years ago by paul

  • Status changed from new to closed
  • Resolution set to fixed

Wasn't able to reproduce it in 1.5a. Closed for now. If you can reproduce any of these next week after 1.5b is out, please add single tickets. Thanks!

Note: See TracTickets for help on using tickets.