Bug Tracker

Modify

Ticket #2128 (closed bug: duplicate)

Opened 6 years ago

Last modified 6 years ago

error xml ajax in internet explorer

Reported by: rleon Owned by:
Priority: minor Milestone: 1.2.4
Component: ajax Version: 1.2.1
Keywords: Cc: hfelici@…
Blocking: Blocked by:

Description

old: var xml = window.ActiveXObject ? new ActiveXObject("Microsoft.XMLHTTP") : new XMLHttpRequest();

new: var xml; if (window.ActiveXObject) {

try {

xml = new ActiveXObject("Msxml2.XMLHTTP");

} catch (e) {

xml = new ActiveXObject("Microsoft.XMLHTTP");

}

} else {

if (window.XMLHttpRequest) {

xml = new XMLHttpRequest();

}

}

Attachments

ajax.js.diff Download (1.3 KB) - added by cmcnulty 6 years ago.
tries more xmlhttp activeX strings if first does not work.

Change History

comment:1 Changed 6 years ago by davidserduke

Is there some test case that displays a problem you are having with the current code?

comment:2 Changed 6 years ago by flesler

  • need changed from Patch to Test Case
  • Milestone changed from 1.2.2 to 1.2.4

comment:3 Changed 6 years ago by cmcnulty

We have a client that is having a problem. We haven't yet been able to reproduce it in house, but we believe it has to do with their use of thin clients/terminal service. They're on IE6/Windows 2000, and they log in as a non-administrator. The symptom we're seeing is that IE throws an error on: new ActiveXObject("Microsoft.XMLHTTP"); , however it does not throw an error on MSXML2.XMLHttp.5.0. We've developed the attached patch for dealing with the issue, and I for one would like to see it encorporated into ajax.js. If nothing else it shouldn't change behavior for existing users.

Changed 6 years ago by cmcnulty

tries more xmlhttp activeX strings if first does not work.

comment:4 Changed 6 years ago by cmcnulty

See #3087 for a better more flexible fix than either the original suggestion or my added patch.

comment:5 Changed 6 years ago by flesler

  • Status changed from new to closed
  • Resolution set to duplicate

The XHR creation process is exposed since [5805] allowing overriding. You can add this code externally.

Please follow the  bug reporting guidlines and use  jsFiddle when providing test cases and demonstrations instead of pasting the code in the ticket.

View

Add a comment

Modify Ticket

Action
as closed
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.