Bug Tracker

Modify

Ticket #2078 (closed bug: invalid)

Opened 6 years ago

Last modified 6 years ago

jQuery( "#element" ).height() returns 0 in Safari 3

Reported by: aarongough Owned by:
Priority: major Milestone: 1.2.2
Component: core Version: 1.2.1
Keywords: safari height ul li returns 0 Cc:
Blocking: Blocked by:

Description

I have not had time to test this on a wide variety of elements but I know that the height is returned incorrectly on UL and LI elements.

The elements being queried are "display: block" and do not have any special positioning applied to them.

Please email me after Dec 21 if you need further testing done.

Change History

comment:1 Changed 6 years ago by aarongough

sorry for the lack of detail, this bug has caught me in the middle of a major project so I am looking for a work-around outside of jQuery for the moment. Thanks for your help! A

comment:2 Changed 6 years ago by aarongough

well it turns out that the bug was being caused by an un-related error ( apparently 'length' is treated as a reserved word by both IE & safari ). I tried to close the ticket but I can't work out how.

Sorry for the hassle. A

comment:3 Changed 6 years ago by davidserduke

  • Status changed from new to closed
  • Resolution set to invalid

No problem. Thanks for both reporting the problem and for following up.

Closed based on information from the author.

Please follow the  bug reporting guidlines and use  jsFiddle when providing test cases and demonstrations instead of pasting the code in the ticket.

View

Add a comment

Modify Ticket

Action
as closed
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.