Bug Tracker

Ticket #2041 (closed bug: wontfix)

Opened 7 years ago

Last modified 3 years ago

Firefox: animations don't work on table rows (tr) because display:block; should be display:;

Reported by: beat Owned by:
Priority: minor Milestone: 1.2.2
Component: effects Version: 1.2.1
Keywords: slideUp slideDown table tr display block Cc:
Blocking: Blocked by:

Description

$("tr.contentRowToChange).slideUp("slow");

doesn't work as expected in Firefox 2.0.11, as it changes the display type of the tr element to "block", all the content gets into the first column of table.

I have found that changing display type to "" instead of "block" works on all instances.

 http://jszen.blogspot.com/2004/07/table-rowsrevealed.html

$("tr.contentRowToChange).slideDown("slow");

has another bug: it leaves the space visible, but didn't find why.

Change History

comment:1 Changed 7 years ago by davidserduke

This is likely related to #1082.

comment:2 Changed 7 years ago by john

  • Status changed from new to closed
  • Resolution set to wontfix

You can't slide table rows, as you can't manipulate the height of them. Any solution to this is far too convoluted to implement sanely. It's probably better to just use regular, non-animated, hide and show for now.

comment:3 Changed 4 years ago by addyosmani

#8852 is a duplicate of this ticket.

comment:4 Changed 3 years ago by anonymous

I am in no way needing this for table elements but I don't want to create a new ticket when asking for the same thing.

Why does the display change when using .slideDown()? I don't want display to be set to block. I don't want it to be set to anything.

Note: See TracTickets for help on using tickets.