Bug Tracker

Modify

Ticket #1811 (closed bug: fixed)

Opened 7 years ago

Last modified 6 years ago

accordion animation prevents dynamic content

Reported by: crenix Owned by: joern
Priority: major Milestone: 1.2.2
Component: ui Version: 1.2.1
Keywords: accordion dynamic Cc:
Blocking: Blocked by:

Description

The accordion changes the style of the div that contains it. So at the end of the animation, the style is something like: style="overflow: hidden; height: 109px"

The problem is if you have dynamic content within that accordion, then any new content you add in gets cut off because of the height constraint and overflow.

My suggestion is after the animation is done, to clear the style completely so everything is back to auto.

Change History

comment:1 Changed 6 years ago by paul

  • Owner set to joern

comment:2 Changed 6 years ago by joern

  • Status changed from new to closed
  • Resolution set to fixed

Fixed in latest revision. Added the clearStyle option for this usecase. Won't work in combination with autoheight.

Please follow the  bug reporting guidlines and use  jsFiddle when providing test cases and demonstrations instead of pasting the code in the ticket.

View

Add a comment

Modify Ticket

Action
as closed
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.