Bug Tracker

Ticket #1788 (closed feature: fixed)

Opened 7 years ago

Last modified 7 years ago

$.ajax is allways evaluating scripts

Reported by: fourat Owned by:
Priority: minor Milestone: 1.2.2
Component: ajax Version: 1.2.1
Keywords: Cc:
Blocking: Blocked by:

Description

$.ajax call is allways evaluating returned data from the server
There's no dataType to determine if it should evaluate or not the data.
A dataType='plain' will satisfy the bug.
Detected in v1.2.1

Change History

comment:1 Changed 7 years ago by Bradley

  • Priority changed from blocker to minor
  • Type changed from bug to feature
  • Component changed from core to ajax

comment:2 Changed 7 years ago by Bradley

  • Status changed from new to closed
  • Resolution set to fixed

This is a problem with the documentation and not a bug. Use the dataType "text".

The ajax documentation for dataType has been updated to reflect this:  http://docs.jquery.com/Ajax/jQuery.ajax#toptions

Note: See TracTickets for help on using tickets.