Bug Tracker

Modify

Ticket #1679 (closed bug: fixed)

Opened 7 years ago

Last modified 7 years ago

Sortable - this.parentNode has no properties on core.js

Reported by: ipalaus Owned by: paul
Priority: critical Milestone: 1.2.2
Component: ui Version: 1.2.1
Keywords: core.js parentNode Opera Cc: ipalaus@…,daijo@…
Blocking: Blocked by:

Description

I had troubles while using Opera and ui.sortables.js recently. I had a list using <li> with a simple Sortable() and it worked fine on the two major browsers (Firefox, IE 6/7). Testing against Opera 9.23 it didn't work. Opera 9.5 alpha release "Kestrel" works fine. When I check on Firefox another time using Firebug i found that when you start moving some Sortable element the console is continuously adding errors and never stops with "this.parentNode has no properties" (line 1098 on core.js).

jQuery version: 1.2.1 and current version (svn) UI version: 1.0 and current version (svn)

Failed failed with both stable and SVN, jQuery and UI

You can check this on  http://dev.jquery.com/view/trunk/plugins/ui/demos/ui.sortable.html

Attachments

ui.sortable.patch Download (467 bytes) - added by swent 7 years ago.

Change History

comment:1 Changed 7 years ago by rworth

  • Component changed from core to ui

comment:2 Changed 7 years ago by rworth

  • Summary changed from this.parentNode has no properties on core.js to Sortable - this.parentNode has no properties on core.js

comment:3 Changed 7 years ago by krunkosaurus

I find something similar happens without the use of additional parameters.

I use Mac Firefox and am also experiencing the above - only able to move a list item once and then JS erros. I see the following infinite error in my Firebug console:

self.pos has no properties [Break on this error] position: { left: self.pos[0], top: self.pos[1] }, ui.sortable.js (line 91)

this.parentNode has no properties [Break on this error] this.parentNode.removeChild( this ); jquery.js (line 1075)

this.parentNode has no properties [Break on this error] null jquery.js (line 1075)

I get similar errors when using this sort method with my own list items and downloaded ui components. I am running the most recent version of jQ and ui components.

comment:4 Changed 7 years ago by paul

  • Owner set to john

Changed 7 years ago by swent

comment:5 Changed 7 years ago by swent

I found a way to fix those errors (see ui.sortable.patch). I'm not sure, whether this fixes the root cause or just the symptom.

Hope this helps

--Swen

comment:6 Changed 7 years ago by john

  • Owner changed from john to paul

comment:7 Changed 7 years ago by paul

  • Status changed from new to closed
  • Resolution set to fixed

Thanks, fixed!

Please follow the  bug reporting guidlines and use  jsFiddle when providing test cases and demonstrations instead of pasting the code in the ticket.

View

Add a comment

Modify Ticket

Action
as closed
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.