Bug Tracker

Modify

Ticket #1465 (closed bug: wontfix)

Opened 7 years ago

Last modified 6 years ago

Interface 1.2: iDrag.js - cloned objects can not be made draggable in iE

Reported by: paolo Owned by: stefan
Priority: minor Milestone: 1.1.4
Component: interface Version: 1.1.3
Keywords: Cc:
Blocking: Blocked by:

Description

Hi,

I discovered that when you have a Draggable jQuery object and then clone that object, you can not make the cloned object draggable (nor is it draggable automatically by the cloning process). At least, not in IE. This is caused by a test in idrag.js around line 495, that tests for the isDraggable property of the object, and returns when it is already draggable. When you comment the 'return' statement the problem is solved (though there may be side-effects, I did not test that). These are the lines concerned:

return this.each(

function()

{

if (this.isDraggable
!jQuery.iUtil)

return this is the 'malicious' line

if (window.ActiveXObject) {

this.onselectstart = function(){return false;}; this.ondragstart = function(){return false;};

}

BTW In Firefox everything works ok. As usual.

Change History

comment:1 Changed 7 years ago by john

  • Owner set to stefan
  • Component changed from core to interface

comment:2 in reply to: ↑ description Changed 7 years ago by Hurreman

Not sure if it has to do with my implementation or not, but one side effect I ran into:

Line: 444 Error: 'dragCfg.oC.x' is null or not an object

The line: dragged.dragCfg.nx = dragged.dragCfg.oC.x + dx - dragged.dragCfg.diffX;

comment:3 Changed 6 years ago by scott.gonzal

  • Status changed from new to closed
  • Resolution set to wontfix

Interface is no longer supported; consider switching to  jQuery UI.

Please follow the  bug reporting guidlines and use  jsFiddle when providing test cases and demonstrations instead of pasting the code in the ticket.

View

Add a comment

Modify Ticket

Action
as closed
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.