Bug Tracker

Modify

Ticket #14401 (closed bug: fixed)

Opened 7 months ago

Last modified 7 months ago

Error when loading a page with application/xhtml+xml

Reported by: hrpeters@… Owned by:
Priority: undecided Milestone: 1.11/2.1
Component: support Version: 2.1.0-beta1
Keywords: Cc:
Blocking: Blocked by:

Description

The new 2.1.0 Beta jQuery won't load into a XHTML page. The following error is being displayed:

SyntaxError: An invalid or illegal string was specified

The problem is line 3974

it reads

div.innerHTML = "<input type='radio' checked name='t'/>";

After changing that to

div.innerHTML = "<input type='radio' checked='checked' name='t'/>";

things seem to work fine so far.

Change History

comment:1 Changed 7 months ago by gibson042

  • Status changed from new to closed
  • Resolution set to fixed
  • Component changed from unfiled to support
  • Milestone changed from None to 1.11/2.1
Last edited 7 months ago by gibson042 (previous) (diff)

Please follow the  bug reporting guidlines and use  jsFiddle when providing test cases and demonstrations instead of pasting the code in the ticket.

View

Add a comment

Modify Ticket

Action
as closed
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.