Bug Tracker

Modify

Ticket #1352 (closed bug: invalid)

Opened 7 years ago

Last modified 2 years ago

[@checked] CSS style selector causes "Object doesn't support this property or method"

Reported by: pocketninja Owned by:
Priority: minor Milestone: 1.1.4
Component: core Version: 1.1.3
Keywords: input checkbox selector Cc:
Blocking: Blocked by:

Description

When getting all checkboxes contained within a div, which have a checked value, IE 6 and 7 return a vague error when there are checkboxes which haven't had the attribute checked set in the HTML source: "Object doesn't support this property or method"

JS code is: var selected = $('div#divID input[@type=checkbox][@checked]');

Can work around by using $.browser.msie with $('div#divID input[@type=checkbox]') and iterating through each checkbox.

Apologies if I selected the wrong Component for the ticket! =)

Change History

comment:1 Changed 7 years ago by pocketninja

Please close this ticket.

Turns out the issue was caused by the use of a reserved word outside of jQuery itself, in a completely separate .js file.

Strange that the error was reported as being in the jQuery code...

=)

comment:2 Changed 7 years ago by john

  • Status changed from new to closed
  • Resolution set to invalid

Please follow the  bug reporting guidlines and use  jsFiddle when providing test cases and demonstrations instead of pasting the code in the ticket.

View

Add a comment

Modify Ticket

Action
as closed
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.