Bug Tracker

Ticket #13282 (closed bug: fixed)

Opened 19 months ago

Last modified 18 months ago

QtWebKit -- TypeError: '[object Object]' is not a valid argument for 'Function.prototype.apply' (evaluating 'elem.nodeType')

Reported by: Jason@… Owned by: gibson042
Priority: low Milestone: 2.0
Component: manipulation Version: 2.0b1
Keywords: Cc: rwaldron, Jason@…
Blocking: Blocked by:

Description

This error occurs on all QtWebKit-based browsers.

        for ( ; i < l; i++ ) {
            elem = elems[ i ];

            if ( elem || elem === 0 ) {

                // Add nodes directly
                if ( jQuery.type( elem ) === "object" ) {
                    core_push.apply( nodes, elem.nodeType ? [ elem ] : elem );
---> TypeError: '[object Object]' is not a valid argument for 'Function.prototype.apply' (evaluating 'elem.nodeType') <----

                // Convert non-html into a text node
                } else if ( !rhtml.test( elem ) ) {
                    nodes.push( context.createTextNode( elem ) );

                // Convert html into DOM nodes
                } else {
                    tmp = tmp || fragment.appendChild( context.createElement("div") );

Change History

comment:1 Changed 19 months ago by gibson042

  • Cc rwaldron added
  • Owner set to gibson042
  • Status changed from new to assigned

Per discussion in #jquery-meeting, we're going to back out the core_push.apply( <Array>, <NodeList> ) calls in favor of the older jQuery.merge( <Array>, <NodeList> ), reverting much of  https://github.com/jquery/jquery/commit/dc93f8cbb59d230d707193118124689c6fd930ff et al.

comment:2 Changed 19 months ago by gibson042

  • Status changed from assigned to closed
  • Cc Jason@… added
  • Component changed from unfiled to manipulation
  • Priority changed from undecided to low
  • Milestone changed from None to 1.9.1
  • Resolution set to fixed

comment:3 Changed 19 months ago by Jason@…

Works great. Thanks for looking into it.

comment:4 Changed 19 months ago by sindresorhus

Make sure to file a ticket on QtWebKit if there doesn't already exist one for this issue and add a link here.

 http://trac.webkit.org/wiki/QtWebKitBugs

comment:5 Changed 19 months ago by gibson042

  • Milestone changed from 1.9.1 to 2.0

comment:7 Changed 18 months ago by gibson042

#13574 is a duplicate of this ticket.

Note: See TracTickets for help on using tickets.