Bug Tracker

Ticket #13213 (closed bug: notabug)

Opened 19 months ago

Last modified 16 months ago

.live error

Reported by: gafani@… Owned by:
Priority: undecided Milestone: None
Component: unfiled Version: git
Keywords: Cc:
Blocking: Blocked by:

Description

include  http://code.jquery.com/jquery-latest.js[[BR]]

TypeError:$(...).live is not a function

...tp://api.jquery.com/jquery-wp-content/themes/jquery/js/modernizr.custom.2.6.2.mi....[[BR]]

Change History

comment:1 Changed 19 months ago by manuel.lopez@…

Confirmed here, any page loading version 1.9.0 fires this error. Downgrading to 1.8.3 solves the problem. Should be an urgent issue...

comment:2 follow-up: ↓ 4 Changed 19 months ago by dmethvin

  • Status changed from new to closed
  • Resolution set to notabug

Yes, .live is not in jQuery 1.9 which is being released today. Read the blog post for information.

comment:3 Changed 19 months ago by dmethvin

#13216 is a duplicate of this ticket.

comment:4 in reply to: ↑ 2 Changed 19 months ago by anonymous

Replying to dmethvin:

Yes, .live is not in jQuery 1.9 which is being released today. Read the blog post for information.

can't find any blog post that has further information. pls post a link!

comment:5 follow-up: ↓ 6 Changed 19 months ago by dmethvin

comment:6 in reply to: ↑ 5 Changed 19 months ago by anonymous

Replying to dmethvin:

um,  http://blog.jquery.com

m( that link doesn't say anything about why .live() has been removed

comment:7 follow-up: ↓ 8 Changed 19 months ago by dmethvin

Did you read the upgrade guide that is linked several times in that post, and also several times in the beta announcements that came before it?

comment:8 in reply to: ↑ 7 Changed 19 months ago by anonymous

Replying to dmethvin:

Did you read the upgrade guide that is linked several times in that post, and also several times in the beta announcements that came before it?

i did, but it only says that 1.9 no longer attempts to maintain .live() but not why.

comment:9 follow-up: ↓ 10 Changed 19 months ago by dmethvin

As of jQuery 1.7, the .live() method is deprecated. --  http://api.jquery.com/live/

jQuery 1.7 was released in November 2011, so there's been more than a year of notice. As to why, just read that documentation and you'll see all the disadvantages of .live().

If you are not prepared to make changes in the site's code, either don't upgrade to 1.9.0 or use the jQuery Migrate plugin mentioned in the upgrade guide.

comment:10 in reply to: ↑ 9 Changed 19 months ago by anonymous

Replying to dmethvin:

As of jQuery 1.7, the .live() method is deprecated. --  http://api.jquery.com/live/

jQuery 1.7 was released in November 2011, so there's been more than a year of notice. As to why, just read that documentation and you'll see all the disadvantages of .live().

If you are not prepared to make changes in the site's code, either don't upgrade to 1.9.0 or use the jQuery Migrate plugin mentioned in the upgrade guide.

ok, that helped. thx. after looking for the downsides, i found this site  http://www.jquery4u.com/jquery-functions/on-vs-live-review/ which told me everything i wanted to know - including which alternative to use.

comment:11 Changed 19 months ago by mikesherov

#13220 is a duplicate of this ticket.

comment:12 Changed 16 months ago by rwaldron

#13668 is a duplicate of this ticket.

comment:13 Changed 16 months ago by rwaldron

#13301 is a duplicate of this ticket.

comment:14 Changed 16 months ago by rwaldron

#13266 is a duplicate of this ticket.

comment:15 Changed 16 months ago by rwaldron

#13257 is a duplicate of this ticket.

Note: See TracTickets for help on using tickets.