Bug Tracker

Ticket #12741 (closed bug: fixed)

Opened 2 years ago

Last modified 2 years ago

inconsistent line endings in official jquery-1.8.2.js download

Reported by: oberhamsi Owned by:
Priority: high Milestone: 1.9
Component: build Version: 1.8.2
Keywords: needsreview Cc:
Blocking: Blocked by:

Description

subversion was angy when I tried to add jquery. And to my surprise it was right: jquery-1.8.2.js download has inconsitent line ending.

it seems the sizzle lines are the offenders. before and after sizzle everything has clean "\n". but from line 3668 on i see "\r\n".

I cloned sizzle from github and it doesn't have this problem. i did not try to build jquery to figure out at which steps the '/r' are added.

I expected all lines to end in "\n".

simon@duchov:/tmp$ wget http://code.jquery.com/jquery-1.8.2.js
simon@duchov:/tmp$ grep -n $'\r' jquery-1.8.2.js | head
3668:/*!
3669: * Sizzle CSS Selector Engine
3670: * Copyright 2012 jQuery Foundation and other contributors
3671: * Released under the MIT license
3672: * http://sizzlejs.com/
3673: */
3674:(function( window, undefined ) {
3675:
3676:var cachedruns,
3677:	assertGetIdNotName,

Change History

comment:1 Changed 2 years ago by timmywil

  • Keywords needsreview added
  • Priority changed from undecided to high
  • Status changed from new to open
  • Component changed from unfiled to build
  • Milestone changed from None to 1.8.3

This could be an issue with the build. Needs investigation.

comment:2 Changed 2 years ago by dmethvin

Most likely because it's using the native line endings for jQuery where I build and release in Windows, but the git line endings for the submodules which were built in Unix.

comment:3 Changed 2 years ago by dmethvin

  • Milestone changed from 1.8.3 to 1.9

comment:4 Changed 2 years ago by dmethvin

#12939 is a duplicate of this ticket.

comment:5 Changed 2 years ago by dmethvin

  • Status changed from open to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.