Bug Tracker

Modify

Ticket #12576 (closed bug: notabug)

Opened 19 months ago

Last modified 19 months ago

$.ajax does not call Success Callback function

Reported by: anonymous Owned by:
Priority: undecided Milestone: None
Component: unfiled Version: 1.4.2
Keywords: Cc:
Blocking: Blocked by:

Description

When sending ajax request to my JSON Service method, the method inserts the data into backend and runs return true/false. Sometimes the success callback function is not being called after returning from JSON Service method without exception. I cannot able to reproduce this in my development and qa environments. But it is happening 1 or 2 users for every 1000 users in Production. If that users retry, it works with no issues.

Below is how I am sending ajax request

$.ajax( {

type: "POST", url: jsonSvcUrl + "/SaveItems", dataType: "json", data: JSON.stringify(data), async: false, contentType: "application/json; charset=utf-8", success: SaveSuccess, error: SaveFailed

});

I am using jQuery 1.4.2. Is this a solution for this issue.

Change History

comment:1 Changed 19 months ago by jaubourg

  • Status changed from new to closed
  • Resolution set to notabug

Please ask for support on the forum or IRC. The bug tracker is for reporting bugs against jQuery core.

Please follow the  bug reporting guidlines and use  jsFiddle when providing test cases and demonstrations instead of pasting the code in the ticket.

View

Add a comment

Modify Ticket

Action
as closed
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.