Bug Tracker

Modify

Ticket #12159 (closed bug: duplicate)

Opened 21 months ago

Last modified 21 months ago

1.8rc1: outerHeight() returns object

Reported by: alec Owned by:
Priority: undecided Milestone: None
Component: unfiled Version: 1.8rc1
Keywords: Cc:
Blocking: Blocked by:

Description

I'm currently unable to reproduce this with a fiddle, but after update to 1.8rc1 all my popups are positioned wrong. It looks that outerHeight() returns object in some circumstances.

Change History

comment:1 Changed 21 months ago by dmethvin

  • Status changed from new to closed
  • Resolution set to invalid

Most likely some plugin is duck-punching outerHeight incorrectly. In 1.8, outerHeight can be used as a setter and it would return the jQuery object it was passed.

If you identify that the problem is in a plugin, please let us know which one. However, it is not a bug in jQuery itself.

comment:2 Changed 21 months ago by anonymous

We experienced the same issue (outerHeight returning an object) when we run jquery-1.8.0 with jquery-ui-1.8.16 After upgrading to jquery-ui-1.8.22, the issue seems to have been resolved.

comment:3 Changed 21 months ago by dmethvin

Good to know, since that is the version compatible with jQuery core 1.8. Thanks!

comment:4 Changed 21 months ago by anonymous

In my case, it's caused, simply by calling...

.outerHeight(1)

...using "1" instead of "true"...that works in < 1.8, returns an Object in 1.8

jQuery UI is NOT necessary to cause this.

Please see...

 http://blog.jquery.com/2012/08/09/jquery-1-8-released/comment-page-2/#comment-532620  http://blog.jquery.com/2012/08/09/jquery-1-8-released/comment-page-2/#comment-532629

...I think outerHeight should be change/reverted to accept 1/0 in addition to true/false.

comment:5 Changed 21 months ago by dmethvin

  • Status changed from closed to reopened
  • Resolution invalid deleted

comment:6 Changed 21 months ago by dmethvin

  • Status changed from reopened to closed
  • Resolution set to duplicate

Duplicate of #12293.

Please follow the  bug reporting guidlines and use  jsFiddle when providing test cases and demonstrations instead of pasting the code in the ticket.

View

Add a comment

Modify Ticket

Action
as closed
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.