Bug Tracker

Ticket #11921 (closed bug: invalid)

Opened 3 years ago

Last modified 12 months ago

curCSS issue with jQuery UI

Reported by: Motty Owned by:
Priority: high Milestone: 1.8
Component: css Version: git
Keywords: Cc:
Blocking: Blocked by:

Description

When I use jQuery UI v1.8.18 position utility with jQuery 1.8pre I am getting this error:

Uncaught TypeError: Object function ( selector, context ) {
		// The jQuery object is actually just the init constructor 'enhanced'
		return new jQuery.fn.init( selector, context, rootjQuery );
	} has no method 'curCSS' - jquery-ui.js:10079

I know curCSS is just an alias for jQuery.css, but this seems to break backwards compatibility because when I switch the jQuery version to 1.7.2, the utility works as expected.

Demo:  http://jsfiddle.net/Mottie/mTdGm/

Change History

comment:1 Changed 3 years ago by scott.gonzalez

This is not a bug and jQuery UI master doesn't use curCSS.

comment:2 Changed 3 years ago by dmethvin

  • Status changed from new to closed
  • Resolution set to invalid

Well Scott should know so I'll close this ticket. Just FYI that's a pretty old version. It would be worthwhile reporting these if they are broken with the most recent version of UI.

comment:3 Changed 3 years ago by Motty

Well I was using google's CDN of jQuery UI, I just tested it with the latest version (1.8.21)... same error.

 https://ajax.googleapis.com/ajax/libs/jqueryui/1.8/jquery-ui.js

search through that page, it finds 19 instances of "curCSS"

Last edited 3 years ago by Motty (previous) (diff)

comment:4 Changed 3 years ago by rwaldron

jQuery 1.8pre is not a stable release of jQuery. This should be refiled with jQuery UI so compatibility progress can be tracked.

comment:5 Changed 3 years ago by mikesherov

  • Priority changed from undecided to high
  • Resolution invalid deleted
  • Status changed from closed to reopened
  • Component changed from unfiled to css
  • Milestone changed from None to 1.8

We recently removed jQuery.curCSS in 1.8pre as its been deprecated since jquery 1.3. It appears that jQueryUI still uses $.curCSS heavily. I'm reopening to talk about whether or not it's worth saving 3 bytes to force an incompatibility with latest UI.

comment:6 Changed 3 years ago by mikesherov

  • Status changed from reopened to closed
  • Resolution set to invalid

scott.gonzalez knows what he's doing. I shouldn't have re-opened.

comment:7 Changed 2 years ago by scott.gonzalez

I just added $.curCSS back in UI core in the 1-8-stable branch so that jQuery UI 1.8.22+ can support jQuery 1.8.

 https://github.com/jquery/jquery-ui/commit/98772fd0a1094f7fb2fbe1d8a95557bf2b545f6e

Supporting 18 versions of jQuery core sure is fun :-)

comment:8 Changed 2 years ago by djwillyguevara@…

Update jquery UI too and Solved.

comment:9 Changed 2 years ago by anonymous

New wersion jQuery UI 1.9.0 - I have this problem again.

comment:10 Changed 2 years ago by scott.gonzalez

@anonymous: jQuery UI 1.9.0 never uses curCSS. Please use the forums or StackOverflow for help.

comment:11 follow-up: ↓ 12 Changed 2 years ago by email@…

I have this problem with jQuery UI 1.8.21 Dialog and jQuery 1.8.2

comment:12 in reply to: ↑ 11 Changed 2 years ago by email@…

Replying to email@…:

I have this problem with jQuery UI 1.8.21 Dialog and jQuery 1.8.2

Fixed by using jQuery UI 1.9.0.

comment:13 follow-up: ↓ 14 Changed 2 years ago by raphievila@…

I'm having the same problem with 1.9.2, just install it. Using draggable and hasn't been working since 1.8.21

comment:14 in reply to: ↑ 13 Changed 2 years ago by anonymous

Replying to raphievila@…:

I'm having the same problem with 1.9.2, just install it. Using draggable and hasn't been working since 1.8.21

I found the error... I was using a plug_in that used the jQuery.browser that has been deprecated. Create my own browser detector, delete plug-in and now is working fine. Sorry for that.

comment:15 follow-ups: ↓ 16 ↓ 17 Changed 21 months ago by gorilonmax

I only changed curCSS to css and worked fine.

comment:16 in reply to: ↑ 15 Changed 18 months ago by vikkukkiv@…

Replying to gorilonmax:

I only changed curCSS to css and worked fine.

Thanks for the tip. I did the same, it works.

comment:17 in reply to: ↑ 15 Changed 14 months ago by billygoat

Replying to gorilonmax:

I only changed curCSS to css and worked fine.

Thank you, I replaced curCSS with css and it also started working properly.

comment:18 Changed 12 months ago by anonymous

Corrected simply:

  • Append a string jquery.js
jQuery.curCSS = jQuery.css;
Note: See TracTickets for help on using tickets.