Bug Tracker

Modify

Ticket #11846 (closed bug: duplicate)

Opened 23 months ago

Last modified 23 months ago

animation complete handler shows wrong animation status

Reported by: shabunc@… Owned by: shabunc@…
Priority: undecided Milestone: None
Component: unfiled Version: 1.7.2
Keywords: Cc:
Blocking: Blocked by:

Description

Say, we call animate method on node $el and we if a complete handler. As it said in docs, complete is "a function to call once the animation is complete." Thus, *in case there's no other animation currently running" , $el.is(':animated') in complete handler should return false. It, nevertheless returns true.

Not only this is wrong because of the agreement about complete function, this also makes impossible to check whether other animations are running or not. And this is needed not that rare.

Change History

comment:1 Changed 23 months ago by sindresorhus

  • Owner set to shabunc@…
  • Status changed from new to pending

Thanks for taking the time to contribute to the jQuery project! Please provide a complete reduced test case on jsFiddle to help us assess your ticket.

Additionally, be sure to test against the jQuery Edge version to ensure the issue still exists. To get you started, use this boilerplate:  http://jsfiddle.net/FrKyN/ Open the link and click to "Fork" (in the top menu) to get started.

comment:2 Changed 23 months ago by gnarf

  • Status changed from pending to closed
  • Resolution set to duplicate

comment:3 Changed 23 months ago by gnarf

Duplicate of #7157.

Please follow the  bug reporting guidlines and use  jsFiddle when providing test cases and demonstrations instead of pasting the code in the ticket.

View

Add a comment

Modify Ticket

Action
as closed
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.