Bug Tracker

Ticket #11810 (closed bug: duplicate)

Opened 2 years ago

Last modified 2 years ago

Error looping with $.each if there is a JSON array contains 'length' key

Reported by: b3bakyt@… Owned by:
Priority: undecided Milestone: None
Component: unfiled Version: 1.7.2
Keywords: Cc:
Blocking: Blocked by:

Description

Hello! I had a json array like {

"properties": {

"array": {

"id": "4", "fabric_category_id": "2", "name": "Len", "description": " ", "system_name": "LEN3", "status": "0", "length": "0", "maker": "art (Italy)"

}

}, "status": "success"

}

and faced a problem parsing this data with $.each(data, function(key, val) { }) function the problem was in the "length" key. It somehow stops loop if thereis a "length" in the json array

Change History

comment:1 Changed 2 years ago by dmethvin

  • Status changed from new to closed
  • Resolution set to duplicate

comment:2 Changed 2 years ago by dmethvin

Duplicate of #7260.

Note: See TracTickets for help on using tickets.