Bug Tracker

Ticket #116 (closed enhancement: invalid)

Opened 8 years ago

Last modified 7 years ago

Different Encodings for AJAX

Reported by: john Owned by:
Priority: major Milestone:
Component: ajax Version:
Keywords: iso-8859-1 Cc:
Blocking: Blocked by:

Description

AJAX requests should have an option to support multiple file encodings (for i18n support).

Change History

comment:1 Changed 8 years ago by daniel@…

  • Keywords iso-8859-1 added

fyi: in prototype.js other encoding than uft-8 works if one uses the escape() method instead of the encodeURI() method

comment:2 Changed 8 years ago by avi

I dont know much about this but...

In jQuery we are using: encodeURIComponent().

At  http://xkr.us/articles/javascript/encode-compare/, It says which one is best to use in which condition.

It says this: The escape() method does not encode the + character which is interpreted as a space on the server side as well as generated by forms with spaces in their fields. Due to this shortcoming, you should avoid use of escape() whenever possible. The best alternative is usually encodeURIComponent().

Now this limitation can be bad in many cases. If the problem is being created by encoding... can't it just be removed so that users can use appropriate coding depending on thr need?

comment:3 Changed 8 years ago by joern

  • Status changed from new to closed
  • Resolution set to invalid
Note: See TracTickets for help on using tickets.