Bug Tracker

Modify

Ticket #11528 (closed bug: fixed)

Opened 2 years ago

Last modified 22 months ago

ie8 serialization bug with .html() also hitting html5 tags

Reported by: cmcnulty Owned by:
Priority: low Milestone: 1.8
Component: manipulation Version: 1.7.2
Keywords: Cc:
Blocking: Blocked by:

Description

The ie8 serialization bug (which is fixed in the case of style and script tags) also affects link elements as well as all unknown elements, including all of html5.

 JsFiddle

I have a fix as well as tests staged here:

 https://github.com/cmcnulty/jquery/tree/ie8bug

A pull request is forthcoming.

Change History

comment:1 Changed 2 years ago by rwaldron

Can you provide tests with that patch?

comment:2 Changed 2 years ago by rwaldron

Sorry, I hadn't seen your PR yet.

comment:3 Changed 2 years ago by cmcnulty

comment:4 Changed 2 years ago by sindresorhus

#11372 is a duplicate of this ticket.

comment:5 Changed 2 years ago by sindresorhus

  • Priority changed from undecided to low
  • Status changed from new to open
  • Component changed from unfiled to manipulation

comment:6 Changed 2 years ago by cmcnulty

PR accepted into 1.8pre:

 commit

Ticket can be closed.

comment:7 Changed 2 years ago by dmethvin

Thanks Charles, what should happen is that when this lands in master the ticket will be closed. We'll see...

comment:8 Changed 22 months ago by dmethvin

  • Status changed from open to closed
  • Resolution set to fixed

comment:9 Changed 22 months ago by dmethvin

  • Milestone changed from None to 1.8

Please follow the  bug reporting guidlines and use  jsFiddle when providing test cases and demonstrations instead of pasting the code in the ticket.

View

Add a comment

Modify Ticket

Action
as closed
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.