Bug Tracker

Modify

Ticket #11478 (closed bug: invalid)

Opened 2 years ago

Last modified 5 months ago

DOMException in Google Chrome

Reported by: sarowar.cse@… Owned by:
Priority: low Milestone: None
Component: misc Version: 1.7.1
Keywords: Cc:
Blocking: Blocked by:

Description

When Developer Tools is open Google Chrome is pausing execution at

Sizzle.matchesSelector, jquery-1.7.1.js:5121 showing a message "Paused on exception: 'DOMException'".

I have tried with some previous versions(1.5.1, 1.5.2, 1.6.1) of jquery, but did the same.

Change History

comment:1 Changed 2 years ago by sarowar.cse@…

My Chrome version is 17.0.963.66.

comment:2 Changed 2 years ago by sarowar.cse@…

its ok now :)

it caused by a chrome setting i didn't noticed.

comment:3 Changed 2 years ago by sindresorhus

  • Priority changed from undecided to low
  • Resolution set to invalid
  • Status changed from new to closed
  • Component changed from unfiled to misc

comment:4 Changed 2 years ago by stan@…

Just for the others ran in the same problem. You should switch "Pause on all exceptions" to "Pause on uncaught exceptions" so that the Chrome don't stop at every try-catch block: http://habrastorage.org/storage2/108/0ca/f1b/1080caf1b8e649b2bc17889c4bd901e7.png

comment:5 Changed 22 months ago by Ricardo Peres

The thing is, "Pause on all exceptions" is a very useful thing... I believe jQuery should not throw any kind of exceptions, because if it does, we will be continuously distracted by them and won't know whether they are important - these don't seem so - or not. Just my 5 cents...

comment:6 Changed 21 months ago by dmethvin

I believe jQuery should not throw any kind of exceptions

Sometimes we do operations that throw exceptions, and it's unavoidable. As long as we catch them it shouldn't be a problem. If you'd like to inspect the places where we do that and recommend another course of action, that would be welcome.

comment:7 Changed 7 months ago by dmethvin

#14350 is a duplicate of this ticket.

comment:8 Changed 5 months ago by robert.m.gary@…

This ends up being very annoying in our development environment as well. All our developers and our QA are trained to use the 'stop on exception' to keep our code clean. In addition our automated tests stop on exceptions.

comment:9 Changed 5 months ago by anonymous

invalid bug?

Please follow the  bug reporting guidlines and use  jsFiddle when providing test cases and demonstrations instead of pasting the code in the ticket.

View

Add a comment

Modify Ticket

Action
as closed
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.