Bug Tracker

Ticket #11399 (closed bug: duplicate)

Opened 3 years ago

Last modified 3 years ago

visible content when animating

Reported by: wasikuss Owned by:
Priority: low Milestone: None
Component: effects Version: 1.7.1
Keywords: Cc:
Blocking: Blocked by:

Description

when animating size of content of div his visible area is trimmed to his inner bounds. if the content overflap border or lay out of div then it is trimmed even if overflow is set to visible

here example:  http://jsfiddle.net/wasikuss/sZeG7/

bottom div show how it should work

Change History

comment:1 Changed 3 years ago by wasikuss

i have found that when jQuery calls animate function sets the element overflow to hidden. how can i turn it off?

comment:2 Changed 3 years ago by sindresorhus

  • Priority changed from undecided to low
  • Resolution set to duplicate
  • Status changed from new to closed
  • Component changed from unfiled to effects

The overflow attribute of an element with an animated width or height is set to hidden until after the animation is complete in order to prevent content from overflowing during animations. You can easily override this by setting "overflow: visible !important;" on the animated div.

comment:3 Changed 3 years ago by sindresorhus

Duplicate of #2648.

comment:4 Changed 3 years ago by wasikuss

i have found that is bug in 8414 line

			if ( opt.overflow != null ) {

it should be

			if ( opt.overflow == undefined ) {

then you dont have to use any css tricks like !important

Note: See TracTickets for help on using tickets.