Bug Tracker

Ticket #11311 (closed bug: fixed)

Opened 2 years ago

Last modified 2 years ago

IE8 css 'bottom' returning incorrect value

Reported by: whitney.a.beck@… Owned by: mikesherov
Priority: low Milestone: None
Component: css Version: 1.7.1
Keywords: Cc:
Blocking: Blocked by:

Description

$(...).css('bottom') will return the correct css attribute percent in Chrome and pixel offset in Firefox. However, in IE8 it returns a completely unrelated value. When that same value is passed back in via $(...).css('bottom', x); The attribute is changed, which as the result of the query, should not.

$(...)[0].style.bottom returns the equivalent same value as $(...).css('bottom') in Fx and Chrome, in IE the $(...)[0].style.bottom will return the correct value, where the alternative returns something completely, from all the poking I did, unrelated.

Change History

comment:1 Changed 2 years ago by sindresorhus

  • Owner set to whitney.a.beck@…
  • Status changed from new to pending

Thanks for taking the time to contribute to the jQuery project! Please provide a complete reduced test case on jsFiddle to help us assess your ticket.

Additionally, be sure to test against the jQuery Edge version to ensure the issue still exists. To get you started, use this boilerplate:  http://jsfiddle.net/FrKyN/ Open the link and click to "Fork" (in the top menu) to get started.

comment:2 Changed 2 years ago by whitters

I'm really not sure jquery wants to fix this. I've tried a four or five different messages now, but they're all flagged as spam. I don't even get a captcha to prove I'm no robot. I've even tried just the jsFiddle link.

 http://jsfiddle.net/2Qrwp/

Version 0, edited 2 years ago by whitters (next)

comment:3 Changed 2 years ago by trac-o-bot

  • Status changed from pending to closed
  • Resolution set to invalid

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

comment:4 Changed 2 years ago by whitney.a.beck@…

... I replied. What gives trac-o-bot? Is it because I posted the original ticket before I had a user account?

comment:5 Changed 2 years ago by ajpiano

  • Status changed from closed to reopened
  • Resolution invalid deleted

Yes, that's what happened.

comment:6 Changed 2 years ago by sindresorhus

  • Priority changed from undecided to low
  • Status changed from reopened to open
  • Component changed from unfiled to css

Confirmed in IE8. It returns just a few pixels.

Webkit returns percent, while Firefox/IE9/Opera returns pixels.

 Simplified testcase

comment:7 Changed 2 years ago by mikesherov

By the way, I've been working on getting webkit to return pixels:  https://bugs.webkit.org/show_bug.cgi?id=29084 no idea about IE8's problem though.

comment:8 Changed 2 years ago by mikesherov

  • Owner changed from whitney.a.beck@… to mikesherov
  • Status changed from open to assigned

This is actually a bug in "Dean Edwards Awesome Hack". Not sure if I can get IE8 to return the correct pixel value, but I can get it to return the right percent value, as IE8's currentStyle natively returns percentages like webkit.

comment:9 Changed 2 years ago by Mike Sherov

  • Status changed from assigned to closed
  • Resolution set to fixed

Fix #11311. Percents not pixels for top/left/bottom/right. Closes gh-793.

Changeset: d5e5ce5bd006ae94e9d85949b4f7141642cebf81

comment:10 Changed 2 years ago by mikesherov

#8158 is a duplicate of this ticket.

Note: See TracTickets for help on using tickets.