Bug Tracker

Ticket #11168 (closed bug: wontfix)

Opened 3 years ago

Last modified 2 years ago

slideToggle and css position in IE

Reported by: Alexis Gagnon <laatkeur@…> Owned by:
Priority: low Milestone: None
Component: effects Version: 1.7.1
Keywords: Cc: dmethvin
Blocking: Blocked by:

Description

In all IE version (IE6 to IE9), the slideToggle, slideUp and slideDown functions don't work properly on unordered list when list items have a css position set to relative (and probably absolute and fixed, but you can see the real problem easily with position: relative). If no css position is set, it works fine.

Bug occurs using most jQuery versions I've tried, including the latest (1.7.1), in all versions of IE from IE6 to IE9, on any Windows OS (WinXP, Vista 7).

When you slideDown, the list items will appear beneath the next element and then will slideDown. When you slideUp, it will slideUp but keep the list items beneath the next element and when the slideUp is complete, the list will disappear.

Test this in IE :  http://jsfiddle.net/fZwHR/11/embedded/result/

Change History

comment:1 Changed 3 years ago by Sreejesh Karunakaran <sreekarun@…>

Tested the jsfiddle sample in IE9 (on windows 7). Could not reproduce the behavior.

comment:2 Changed 3 years ago by sindresorhus

 Simplified testcase

I could only reproduce the issue in your jsfiddle in IE6/7. The internetz says it's a  very  well known problem.

The problem is apparent  without jQuery too, so it's not a jQuery bug.

Setting "position: relative; zoom: 1;" on the parent seems to fix the problem.

comment:3 Changed 3 years ago by addyosmani

  • Cc dmethvin added
  • Priority changed from undecided to low
  • Component changed from unfiled to effects

Given this is not a jQuery bug par se (and is well known), do we still want to fix it?

comment:4 Changed 2 years ago by sindresorhus

  • Keywords needsdocs added
  • Status changed from new to open

This is easy for devs to fix themselves. We should document, but not fix.

comment:5 Changed 2 years ago by mikesherov

  • Status changed from open to closed
  • Resolution set to wontfix

needsdocs tickets should be closed. Once the documenting happens, remove the keyword.

comment:6 Changed 2 years ago by gnarf

Honestly, they should become issues on the api repo now instead of lurking here.

comment:7 Changed 2 years ago by sindresorhus

#12431 is a duplicate of this ticket.

comment:8 Changed 2 years ago by mikesherov

  • Keywords needsdocs removed
Note: See TracTickets for help on using tickets.